The discussion forums in the XSEDE User Portal are for users to share experiences, questions, and comments with other users and XSEDE staff. Visitors are welcome to browse and search, but you must login to contribute to the forums. While XSEDE staff monitor the lists, XSEDE does not guarantee that questions will be answered. Please note that the forums are not a replacement for formal support or bug reporting procedures through the XSEDE Help Desk. You must be logged in to post to the user forums.

« Back

Intel(R) AVX support: CP2K module on stampede2 KNL node

Combination View Flat View Tree View
Threads [ Previous | Next ]
Hello,
Trying to use CP2K software that is available as a module. The command "cp2k.popt" works on login node but fails on the stampede2 KNL nodes. See below:
------------------------
login2(1040)$ idev -N 1 -p normal
------------------------
c417-061(980)$ module list

Currently Loaded Modules:
1) git/2.9.0 3) cmake/3.10.2 5) TACC 7) libfabric/1.7.0 9) python2/2.7.14
2) autotools/1.1 4) xalt/2.6.5 6) intel/17.0.4 8) impi/17.0.3 10) cp2k/6.1.0
------------------------
c417-061(979)$ cp2k.popt

Please verify that both the operating system and the processor support Intel(R) AVX512DQ, AVX512BW and AVX512VL instructions.
------------------------
Tried to google this but not getting anywhere.. Not an expert in system architecture. Any help would be great!
Thanks
Ajay